over 6 years ago

當打下rvm install 1.9.2指令的時候,會出現

The provided compiler '/usr/bin/gcc' is LLVM based, it is not yet fully supported by ruby and gems, please read `rvm requirements`.

簡單的說就是他不吃llvb-gcc,所以我們要想辦法生一個標準的gcc給rvm編譯ruby

解決方法可以很麻煩,也可以很簡單,比較好的作法是去抓gcc的原始碼回來自己編譯,但會花不少時間在編譯上面,如果有興趣的話,可以參考強者我同學(好吧其實只是社團的同學..)鴨七blog的教學

如果你跟我一樣懶的話,就抓別人包好的gcc回來用吧,我抓回來測試的結果是一切安好,可以正常執行

別人包好的gcc

抓回來之後打開,直接安裝,安裝完之後不需要另外設定目錄之類的,直接rvm install 1.9.2重跑一次剛剛你失敗的安裝即可,唯一的差別是這次rvm能夠正常編譯ruby並順利完成安裝 :)

← [閒聊] 使用octopress一段時間後的心得 [教學] 在Windows下建立GNU編譯環境 →